const regex = /<form[^>]*>((?!<\/form>).)*<\/form>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<form[^>]*>((?!<\\\/form>).)*<\\\/form>', 'gim')
const str = `<p>Hey I am a boy</p>
<form id='id1' class='class1'>Content</form>
<p>Hey I am a girl</p>
<form id='id1' class='class1'>content</form>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);