# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<form[^>]*>((?!<\/form>).)*<\/form>"
test_str = ("<p>Hey I am a boy</p>\n"
"<form id='id1' class='class1'>Content</form>\n"
"<p>Hey I am a girl</p>\n"
"<form id='id1' class='class1'>content</form>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.