#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)"
Local $sString = "nissan" & @CRLF & _
"Company name nissan and Nissan Micra product." & @CRLF & _
"<p>Company name nissan and Nissan Micra product.</p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"You know Nissan become now http://www.nissan.com. " & @CRLF & _
"<p>www.nissan.com </p>" & @CRLF & _
"<p>Now nissan become now www.nissan.com</p>" & @CRLF & _
"<p>Hello you know Nissan is Now nissan become now www.nissan.com</p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")