import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\\n))*</(?:a|span)>)";
final String string = "nissan\n"
+ "Company name nissan and Nissan Micra product.\n"
+ "<p>Company name nissan and Nissan Micra product.</p>\n\n\n"
+ "You know Nissan become now http://www.nissan.com. \n"
+ "<p>www.nissan.com </p>\n"
+ "<p>Now nissan become now www.nissan.com</p>\n"
+ "<p>Hello you know Nissan is Now nissan become now www.nissan.com</p>\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}