const regex = new RegExp('[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\\n))*</(?:a|span)>)', 'gim')
const str = `nissan
Company name nissan and Nissan Micra product.
<p>Company name nissan and Nissan Micra product.</p>
You know Nissan become now http://www.nissan.com.
<p>www.nissan.com </p>
<p>Now nissan become now www.nissan.com</p>
<p>Hello you know Nissan is Now nissan become now www.nissan.com</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}