use strict;
my $str = 'nissan
Company name nissan and Nissan Micra product.
<p>Company name nissan and Nissan Micra product.</p>
You know Nissan become now http://www.nissan.com.
<p>www.nissan.com </p>
<p>Now nissan become now www.nissan.com</p>
<p>Hello you know Nissan is Now nissan become now www.nissan.com</p>
';
my $regex = qr/[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}