$re = '/[Nn]issan(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)/im';
$str = 'nissan
Company name nissan and Nissan Micra product.
<p>Company name nissan and Nissan Micra product.</p>
You know Nissan become now http://www.nissan.com.
<p>www.nissan.com </p>
<p>Now nissan become now www.nissan.com</p>
<p>Hello you know Nissan is Now nissan become now www.nissan.com</p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);