#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a\s.*href\s?=\s?["'](\bmailto:\b|\bhttp:\/\/\b|\bhttps:\/\/\b).*["'].*?>.*?<\/a>"
Local $sString = "<a style="" href="https://www.dr.dk'>click here</a>" & @CRLF & _
"<a style="" href="http://www.dr.dk'>click here</a>" & @CRLF & _
"<a href = "http://www.dr.dk'>click here</a>" & @CRLF & _
"<ahref="https://www.dr.dk'>click here</a> Error in tag" & @CRLF & _
"<a href = https://www.dr.dk>click here</a> No quote marks" & @CRLF & _
"<a href="https://www.dr.dk"> c l i c k h e r e </a>" & @CRLF & _
"<a href="mailto:ghf">mail</a>" & @CRLF & _
"<a href="https://www.dr.dk" class="link"> c l i c k h e r e </a>" & @CRLF & _
"<a href ="https://www.dr.dk" class="link"> c l i c k h e r e </a>" & @CRLF & _
"<A HREF = "http://">hej</a> <-No link" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")