package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`time=+([0-9]*.[0-9]{2})`)
var str = `28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}