// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"time=+([0-9]*.[0-9]{2})").unwrap();
let string = "28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}