import re
regex = re.compile(r">.*?([^<]+)")
test_str = "<a rel=\"profile-edit\" class=\"app js-user-name\" href=\"/profile/0471482493?from_my_profile=1\">Mia</a></b> <"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)