import Foundation
let pattern = #">.*?([^<]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<a rel="profile-edit" class="app js-user-name" href="/profile/0471482493?from_my_profile=1">Mia</a></b> <"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}