# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<li[^<]*>)([^>]*<\\/li>)(?=(?![\s\S]*?<ol[^<]*>)[\s\S]*?<\\/ol>)/$1 $2/g;t' <<< "<ol>
<li>This is a new list</li>
<ol>
<li>Embedded List</li>
<li>Embedded List</li>
</ol>
</ol>"