#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<li[^<]*>)([^>]*<\/li>)(?=(?![\s\S]*?<ol[^<]*>)[\s\S]*?<\/ol>)"
Local $sString = "<ol>" & @CRLF & _
" <li>This is a new list</li>" & @CRLF & _
" <ol>" & @CRLF & _
" <li>Embedded List</li>" & @CRLF & _
" <li>Embedded List</li>" & @CRLF & _
" </ol>" & @CRLF & _
" </ol>"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)