const regex = /(https?:\/\/)?(www.)?(youtube\.com|youtu\.be|youtube-nocookie\.com)\/(?:embed\/|v\/|watch\?v=|watch\?list=(.*)&v=|watch\?(.*[^&]&)v=)?((\w|-){11})(&list=(\w+)&?)?/gims;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www.)?(youtube\\.com|youtu\\.be|youtube-nocookie\\.com)\\\/(?:embed\\\/|v\\\/|watch\\?v=|watch\\?list=(.*)&v=|watch\\?(.*[^&]&)v=)?((\\w|-){11})(&list=(\\w+)&?)?', 'gims')
const str = `https://www.youtube.com/watch?t=30&v=nt4fMMCNdRk
https://www.youtube.com/watch?v=-RWl24TUW6g
https://youtu.be/O5jUi3kBins
https://youtu.be/O5jUi3kBins?t=16s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}