import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'(.*?\\.co\\.uk)'";
final String string = " (9,'zxvvgf@housecapades.com',0,0,1,1,0,1,1),\n"
+ " (10,'qwer@rogers.co.uk',1,0,0,1,0,0,1),\n"
+ " (11,'lorenIpsum@hotmail.com',0,0,0,1,0,0,1),\n"
+ " (12,'BarackObama@googlemail.co.uk',1,0,9,1,1,1,1),\n"
+ " (13,'DonaldTrump@courtesysupportteam.net',0,0,9,1,1,1,1),\n"
+ " (15,'Mcaine@mynet.com',1,0,9,1,1,1,1),\n"
+ " (16,'davestra_@hotmail.com',0,0,0,1,0,0,1),\n"
+ " (17,'lewisHamilton@carracing.co.uk',1,0,9,1,1,1,1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}