re = /'(.*?\.co\.uk)'/
str = ' (9,\'zxvvgf@housecapades.com\',0,0,1,1,0,1,1),
(10,\'qwer@rogers.co.uk\',1,0,0,1,0,0,1),
(11,\'lorenIpsum@hotmail.com\',0,0,0,1,0,0,1),
(12,\'BarackObama@googlemail.co.uk\',1,0,9,1,1,1,1),
(13,\'DonaldTrump@courtesysupportteam.net\',0,0,9,1,1,1,1),
(15,\'Mcaine@mynet.com\',1,0,9,1,1,1,1),
(16,\'davestra_@hotmail.com\',0,0,0,1,0,0,1),
(17,\'lewisHamilton@carracing.co.uk\',1,0,9,1,1,1,1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end