use strict;
my $str = '<<<<<<< HEAD
Release.AspNetCompiler.VirtualPath = "/agsdasgd"
Release.AspNetCompiler.PhysicalPath = "Server\\PATH\\afgdafgd\\"
Release.AspNetCompiler.TargetPath = "PrePATH\\to\\PATH\\afgdafdgPATH\\"
=======
Release.AspNetCompiler.VirtualPath = "/afdgafdPATH"
Release.AspNetCompiler.PhysicalPath = "PATH\\PATH\\PATH\\"
Release.AspNetCompiler.TargetPath = "PATHYPATH\\afdgadfg\\"
>>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
afds
fgds
testing
<<<<<<< HEAD
kljasdfasfd
sadfkljasdf
kdjsfla
k
afjdsl
asfdkljafsdk
jlfsadkj
lasfdk
jl
=======
fadsjkl
fdaskj
lfdas
jklfadsk
ljafdsjkl
fadsk
ljafdsk
jlafdskj
ladfs
kjlfdask
ljfadskj
ladfsk
jl
>>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
fds
fads
afds
fads
';
my $regex = qr/<{7}[ ]HEAD[\r\n]{1,2}([\S\s]*?)(?:={7}[\r\n]{1,2}((?:[\S\s]?(?!(>{7}[ ][a-z0-9]{40})))*[\r\n]?)(?:>{7}[ ][a-z0-9]{40}[\r\n]{0,2})?)/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}