# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<{7}[ ]HEAD[\r\n]{1,2}([\S\s]*?)(?:={7}[\r\n]{1,2}((?:[\S\s]?(?!(>{7}[ ][a-z0-9]{40})))*[\r\n]?)(?:>{7}[ ][a-z0-9]{40}[\r\n]{0,2})?)
"""
test_str = ("<<<<<<< HEAD\n"
" Release.AspNetCompiler.VirtualPath = \"/agsdasgd\"\n"
" Release.AspNetCompiler.PhysicalPath = \"Server\\PATH\\afgdafgd\\\"\n"
" Release.AspNetCompiler.TargetPath = \"PrePATH\\to\\PATH\\afgdafdgPATH\\\"\n"
"=======\n"
" Release.AspNetCompiler.VirtualPath = \"/afdgafdPATH\"\n"
" Release.AspNetCompiler.PhysicalPath = \"PATH\\PATH\\PATH\\\"\n"
" Release.AspNetCompiler.TargetPath = \"PATHYPATH\\afdgadfg\\\"\n"
">>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\n"
"afds\n"
"fgds\n"
"testing\n"
"<<<<<<< HEAD\n"
"kljasdfasfd\n"
"sadfkljasdf\n"
"kdjsfla\n"
"k\n"
"afjdsl\n"
"asfdkljafsdk\n"
"jlfsadkj\n"
"lasfdk\n"
"jl\n"
"=======\n"
"fadsjkl\n"
"fdaskj\n"
"lfdas\n"
"jklfadsk\n"
"ljafdsjkl\n"
"fadsk\n"
"ljafdsk\n"
"jlafdskj\n"
"ladfs\n"
"kjlfdask\n"
"ljfadskj\n"
"ladfsk\n"
"jl\n"
">>>>>>> aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\n"
"fds\n"
"fads\n"
"afds\n"
"fads\n")
matches = re.search(regex, test_str, re.VERBOSE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.