import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d|[1-2]\\d|3[01]|99)$";
final String string = "0\n"
+ "2\n"
+ "01\n"
+ "10\n"
+ "15\n"
+ "23\n"
+ "31\n"
+ "32\n"
+ "99\n"
+ "100\n"
+ "000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}