$re = '/^(\d|[1-2]\d|3[01]|99)$/m';
$str = '0
2
01
10
15
23
31
32
99
100
000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);