# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)//gm;t' <<< "_@##%Default__$*_123_"