use strict;
my $str = '_@##%Default__$*_123_';
my $regex = qr/(?!_)[[:punct:]]|^_+|[[:punct:]]+(?=_|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";