Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(-|\s*|\/\/|\/\*|<!--|\*|[*[0-9.]*)(\s*)(TAG|d])(-*|:*|\s*)(.*)
/
gm
Input 1
1
New
// TAG: this is bug! // TAG: this is bug! \t // TAG: this is bug! <!-- TAG: this is a hack! <!-- TAG: this is a hack! * TAG: need to fix this - TAG - TAG: this is a todo! /* TAG: this is a todo! // TAG: warning or ignore - [ ] this is an unfinished item - [x] this item is finished - [/] this item is finished TAG: I said something my comment - TAG TAG attention! ?? question? ## Sample [1.2d] | E2E QA & Debugging [0.6d] | Release ~~ 14.9d ~~ 19d