const regex = /(-|\s*|\/\/|\/\*|<!--|\*|[*[0-9.]*)(\s*)(TAG|d])(-*|:*|\s*)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-|\\s*|\\\/\\\/|\\\/\\*|<!--|\\*|[*[0-9.]*)(\\s*)(TAG|d])(-*|:*|\\s*)(.*)', 'gm')
const str = `// TAG: this is bug!
// TAG: this is bug!
\\t // TAG: this is bug!
<!-- TAG: this is a hack!
<!-- TAG: this is a hack!
* TAG: need to fix this - TAG
- TAG: this is a todo!
/* TAG: this is a todo!
// TAG: warning or ignore
- [ ] this is an unfinished item
- [x] this item is finished
- [/] this item is finished
TAG: I said something
my comment - TAG
TAG attention!
?? question?
## Sample
[1.2d] | E2E QA & Debugging
[0.6d] | Release
~~ 14.9d
~~ 19d
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}