Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
`
^([a-z])([a-z\d\-]+)([a-z])$
`
gm
Test String
New
blah blah-blah blah-blah34 blah-bl2334sdf blah-1pass blah- -blah blah_blah