package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z])([a-z\d\-]+)([a-z])$`)
var str = `blah
blah-blah
blah-blah34
blah-bl2334sdf
blah-1pass
blah-
-blah
blah_blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}