re = /^([a-z])([a-z\d\-]+)([a-z])$/m
str = 'blah
blah-blah
blah-blah34
blah-bl2334sdf
blah-1pass
blah-
-blah
blah_blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end