$re = '/^[^\d\n\r]*\d+(?:[,.]\d+)*([^\d\n\r]+)\d/m';
$str = 'testsfa13.4extractthis8488.9090testssffwwww
ajfafs-sss133.6extractthis887878.222testtest522252.9thismore';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);