#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Street Improvements\s+).+(?=\sProject)"
Local $sString = "Return to Contents" & @CRLF & _
"" & @CRLF & _
"Street Improvements" & @CRLF & _
"" & @CRLF & _
"Ocotillo Road – Greenfield to Higley Project #: ST0540" & @CRLF & _
"" & @CRLF & _
"Project Description:" & @CRLF & _
"Design and construction of Ocotillo Road from approximately ¼ mile east of Greenfield Road to Higley Road to" & @CRLF & _
"minor arterial standards. The project includes crossings over the Queen Creek Wash, East Maricopa Floodway," & @CRLF & _
"Roosevelt Water Conservation District Canal and Chandler Heights Basin. The project includes the relocation of" & @CRLF & _
"69kV power lines and access into the proposed Gilbert Regional Park." & @CRLF & _
"" & @CRLF & _
"Project Information:" & @CRLF & _
"• Costs shown in prior years are for completion of an alignment study in FY 2009" & @CRLF & _
"to coordinate the alignment with Flood Control District projects" & @CRLF & _
"• Maintenance costs will be determined once final design is completed. Ongoing" & @CRLF & _
"maintenance costs will be a consideration in selection of the project design" & @CRLF & _
"• Project is necessary for growth/development and therefore is eligible for" & @CRLF & _
"System Development Fee funding" & @CRLF & _
"" & @CRLF & _
"Financial Information:" & @CRLF & _
"Expenses: (1,000s) Total Prior FY 2021 FY 2022 FY 2023 FY 2024 FY 2025 Years 6- Beyond" & @CRLF & _
"Years 10 10 Yrs" & @CRLF & _
"Professional Services $ 6,104 299 5,805 - - - - - -" & @CRLF & _
"Construction Mgmt $ 4,316 33 4,283 - - - - - -" & @CRLF & _
"Land/ROW $ 2,325 - 2,325 - - - - - -" & @CRLF & _
"Construction $ 53,774 - - 53,774 - - - - -" & @CRLF & _
"Equipment & Furniture $ - - - - - - - - -" & @CRLF & _
"" & @CRLF & _
"Total Expenses $ 66,519 $ 332 $ 12,413 $ 53,774 $ - $ - $ - $ - $ -" & @CRLF & _
"" & @CRLF & _
"Sources: (1,000s)" & @CRLF & _
"" & @CRLF & _
"2007 GO Bonds 08 $ 246 246 - - - - - - -" & @CRLF & _
"2022 Potential Street Bond $ 50,701 - - 50,701 - - - - -" & @CRLF & _
"CIP O/S Revolving Fund $ 375 86 289 - - - - - -" & @CRLF & _
"Roads SDF $ 15,197 - 12,124 3,073 - - - - -" & @CRLF & _
"" & @CRLF & _
"Total Sources $ 66,519 $ 332 $ 12,413 $ 53,774 $ - $ - $ - $ - $ -" & @CRLF & _
"" & @CRLF & _
"Operation and Maintenance Impact: (1,000s)" & @CRLF & _
"" & @CRLF & _
"Personnel - - - - -" & @CRLF & _
"Contractual Services - - - - -" & @CRLF & _
"Supplies - - - - -" & @CRLF & _
"Utilities - - - - -" & @CRLF & _
"Insurance - - - - -" & @CRLF & _
"" & @CRLF & _
"Total O&M Impact $ - $ - $ - $ - $ -" & @CRLF & _
"" & @CRLF & _
"Total Revenue $ - $ - $ - $ - $ -" & @CRLF & _
"" & @CRLF & _
"49"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")