using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(profiles|id)\/([\w-]*)";
string input = @"https://steamcommunity.com/id/rafa_br34/
https://steamcommunity.com/id/rafa_br34/allcomments
https://steamcommunity.com/profiles/76561198449824687/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}