$re = '/[^\w.]+|\.(?=[^.]*\.)/m';
$str = 'daryaa-manmarziyan-(VideoStatus.Net).mp4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;