$re = '/\/\*\*![^*]*\*+(?:[^\/*][^*]*\*+)*\//m';
$str = '/**!
* Plugin Name 1.0.0
* @author Name
*/
/*! Test */
/* Test */
/************************************************************************/
/******/ /* Test */
/******/
/*!*********************!*\\
!*** ./index.ts ***!
\\*********************/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);