re = /\/\*\*![^*]*\*+(?:[^\/*][^*]*\*+)*\//m
str = '/**!
* Plugin Name 1.0.0
* @author Name
*/
/*! Test */
/* Test */
/************************************************************************/
/******/ /* Test */
/******/
/*!*********************!*\\
!*** ./index.ts ***!
\\*********************/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end