// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mix)(?(DEFINE)
(?<tagnames> @CUSTOM-AT-1 | @CUSTOM-AT-2)
(?<number> -? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)? )
(?<boolean> true | false | null )
(?<string> \" ([^\"\\\\]* | \\\\ [\"\\\\bfnrt\/] | \\\\ u [0-9a-f]{4} )* \" )
(?<array> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] )
(?<pair> \s* (?&string) \s* : (?&json) )
(?<object> \{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} )
(?<fieldname> [a-zA-Z0-9\_\-]+ )
(?<json> \s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) )
(?<fieldlist> (?: (?&fieldname) (?: , (?&fieldname) )+ )+ ) )
(?<actiontag> (?&tagnames)
)
(?:\=
(?'params'
(?:
(?'match_list'(?&fieldlist))
|
(?'match_json'(?&json))
|
(?'match_string'(?:[[:alnum:]\_\-]+))
)
)
)"#).unwrap();
let string = "@FIELDLIST=field_1,field_2
@STRING=\"Bar\"
@JSON={\"foo\":\"bar\"}
@CUSTOM-AT-2={\"strict\":true, \"targets\":[\"field_3\", \"field_7\"], \"title\":\"Custom Title\", \"message\":\"This is a custom message\"}
@CUSTOM-AT-1={\"strict\":true, \"targets\":[\"field_3\", \"field_7\"], \"title\":\"Custom Title\", \"message\":\"This is a custom message\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}