re = /^(?:(?!.*[a-z])|(?!.*[A-Z])|(?!.*[[:digit:]])|(?!.*[[:punct:]])|(?!.{8,32}$)).*/m
str = 'abcD12-q
123abcZy@
abcD12rq
a@bD1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end