using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\-?\$[0-1][0-5]+(\.[0-9]{2,2})?$|^\-?\$[0-5]+(\.[0-9]{2,2})?$";
string input = @"$12.15
$5.99
$18.99
$05.5
$526262100.41
$.99";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}