using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[)[^\]]+(?=\])";
string substitution = @"$1";
string input = @"I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}