import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Match[\\s\\S]*?(?=^$|\\Z)";
final String string = "Match User thedomain\\user1\n"
+ " ChrootDirectory E:\\sftp\\heatism\\user1\n"
+ " PermitTunnel no\n"
+ " AllowAgentForwarding no\n"
+ " AllowTcpForwarding no\n"
+ " X11Forwarding no\n"
+ " ForceCommand internal-sftp\n\n"
+ "Match User thedomain\\user2\n"
+ " ChrootDirectory E:\\sftp\\heatism\\user2\n"
+ " PermitTunnel no\n"
+ " AllowAgentForwarding no\n"
+ " AllowTcpForwarding no\n"
+ " X11Forwarding no\n"
+ " ForceCommand internal-sftp\n\n"
+ "Match User thedomain\\user3\n"
+ " ChrootDirectory E:\\sftp\\heatism\\user3\n"
+ " PermitTunnel no\n"
+ " AllowAgentForwarding no\n"
+ " AllowTcpForwarding no\n"
+ " X11Forwarding no\n"
+ " ForceCommand internal-sftp";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}