$re = '/([\.\#]?[a-z]+[\s?>+~\s?[a-z]+]?)|([{:};])|([a-z0-9]+)/i';
$str = '.box {
background: red;
color: white;
}
div > span {
}
#p+span{
display:none;
}
tr ~td{
opacity:1;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);