$re = '/^((?!cat|\?).)+$/m';
$str = 'https://site.ru/?a=1
https://site.ru/cat1.html
https://site.ru/cat1/
https://site.ru/test
чтобы были выбраны только те строки, в которых нет знака вопроса и слова "cat"? ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);