$re = '/^.*(cat|test).*$/m';
$str = 'https://site.ru/?a=1
https://site.ru/cat1.html
https://site.ru/cat1/
https://site.ru/test
https://site.ru/test
https://site.ru/tsadasdas
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);