#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#[\w\d][\w\-]*"
Local $sString = "#hashtag some text #hash; #123" & @CRLF & _
" and # not because markdown" & @CRLF & _
"# that not" & @CRLF & _
"#33 that is not " & @CRLF & _
"either but #3isok " & @CRLF & _
" or #isok3" & @CRLF & _
"astring#andthatshouldnotmatch " & @CRLF & _
" #hashtagalone" & @CRLF & _
" \n#hashatthebeginning" & @CRLF & _
"hello #hashattheend\n" & @CRLF & _
"#has_htag " & @CRLF & _
"#ano-the-rone"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")