$re = '/[_\w;]/m';
$str = 'this_isTest;sentence
this new _isTest;sentence
again _isTest; sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);