$re = '/(?<=\?{3})\d+|\d+(?=\?{3})/m';
$str = 'acc5???7???7ss?3rr1??5
5???abc???3
5????abc2???xyz????1abc???3abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);