import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|[1-9][0-9]*)$";
final String string = "xdzbcqhbucbsd\n"
+ "8148419984\n"
+ "86164849484914\n"
+ "61814671\n"
+ "-49848489\n"
+ "844848484\n"
+ "8484818478484845484818454754848484848484848484548485184849848984984\n"
+ "8484848484884848984848\n"
+ "9848498498498498499848\n"
+ "40800\n"
+ "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}