# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:0?[1-9]\d*(?:\.\d*[0-9]*)?)|(:?^0.[1-9]+0?)$"
test_str = ("VALID\n"
"_______\n"
"40000\n"
"45\n"
"4\n"
"45.67\n"
"67.8\n"
"60.\n"
"61.0\n"
"1.00\n"
"01.00\n"
"02.00\n"
"03.0\n"
"89.50\n"
"50.00\n"
"0.10\n"
"0.1\n"
"0.2\n"
"0.3\n"
"0.03\n\n"
"NOT VALID\n"
"_______\n"
"0.00\n"
"00000\n"
"0.0\n"
"0\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.