Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:#(?:[A-Fa-f0-9]{3}){1,2}|(?:rgb[(](?:\s*0*(?:\d\d?(?:\.\d+)?(?:\s*%)?|\.\d+\s*%|100(?:\.0*)?\s*%|(?:1\d\d|2[0-4]\d|25[0-5])(?:\.\d+)?)\s*(?:,(?![)])|(?=[)]))){3}|hsl[(]\s*0*(?:[12]?\d{1,2}|3(?:[0-5]\d|60))\s*(?:\s*,\s*0*(?:\d\d?(?:\.\d+)?\s*%|\.\d+\s*%|100(?:\.0*)?\s*%)){2}\s*|(?:rgba[(](?:\s*0*(?:\d\d?(?:\.\d+)?(?:\s*%)?|\.\d+\s*%|100(?:\.0*)?\s*%|(?:1\d\d|2[0-4]\d|25[0-5])(?:\.\d+)?)\s*,){3}|hsla[(]\s*0*(?:[12]?\d{1,2}|3(?:[0-5]\d|60))\s*(?:\s*,\s*0*(?:\d\d?(?:\.\d+)?\s*%|\.\d+\s*%|100(?:\.0*)?\s*%)){2}\s*,)\s*0*(?:\.\d+|1(?:\.0*)?)\s*)[)])$
/
gm
Test String
New
#0F0F0F #123 #1234 #ABC456 #1234567 rgb(1,2,3) rgb(1,2,) rgb(112233) rgb(255,249,199) rgb(256,249,199) rgb(255,249,199,) rgb( 100%, 199, 50%) rgb( 100%, 199%, 50%) rgb(1,2,3%,.5) rgba(1,2,3%,0.75) rgba(1,2,3%,.5) rgba(1,2,.5) rgba(1,2,3) rgba(1,249,100,1) rgba(1,249,100,1.0) rgba(1,249,100,1.1) rgba(255,256,255,1) rgba(1,249.5,100%,1) rgba(1,249.5,101%,1) hsl(360,2%,100%) hsl(361,2%,100%) hsl(,2%,100%) hsl(360,2%,) hsl(360,2%,0100.00%) hsl(360,2%,101%) hsla(180,2%,100%,0.5) hsla(180,2%,100%,)