import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]+(?:[.\\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\\.)+[a-z]{2,}$";
final String string = "Valid emails:\n"
+ "user@domain.ru\n"
+ "na_me.lastname@subdomain.domain.ru\n"
+ "name-lastname@7.sub-sub-domain.subdomain.domain.ru\n"
+ "ni+ck'name-name.lastname@d.oma-in-domain.ru\n\n"
+ "Invalid addresses in the user section:\n"
+ ".user@domain.ru\n"
+ "user.@domain.ru\n"
+ "-user@domain.ru\n"
+ "user-@domain.ru\n"
+ "us..er@domain.ru\n"
+ "us--er@domain.ru\n\n"
+ "Invalid addresses in the domain section:\n"
+ "user@-domain.ru\n"
+ "user@.subdomain.domain.ru\n"
+ "user@subdomain-.domain.ru\n"
+ "user@subdomain..domain.ru\n"
+ "user@domain.-domain.ru\n"
+ "user@dom--ain.ru";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}