const regex = /^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]+(?:[.\\-_\'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\\.)+[a-z]{2,}$', 'igm')
const str = `Valid emails:
user@domain.ru
na_me.lastname@subdomain.domain.ru
name-lastname@7.sub-sub-domain.subdomain.domain.ru
ni+ck'name-name.lastname@d.oma-in-domain.ru
Invalid addresses in the user section:
.user@domain.ru
user.@domain.ru
-user@domain.ru
user-@domain.ru
us..er@domain.ru
us--er@domain.ru
Invalid addresses in the domain section:
user@-domain.ru
user@.subdomain.domain.ru
user@subdomain-.domain.ru
user@subdomain..domain.ru
user@domain.-domain.ru
user@dom--ain.ru`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}